HDU2199

Problem Description
Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2 100 -4
Sample Output
1.6152 No solution!

#include <iostream>
#include <cmath>
#define EPS 1e-6
using namespace std;
//8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y
double y;
int a[1000];
double f(double x)
{
	return 8 * x * x * x * x + 7 * x * x * x + 2 * x * x + 3 * x + 6; 
}
int main()
{
	int t;
	double x1 = 0, x2 = 100, root;
	root = x1 + (x2 - x1) / 2;
	cin >> t;
	for (int i = 0; i < t; i++)
	{
		cin >> a[i];
	}
	for (int i = 0; i < t; i++)
	{
		x1 =0, x2 = 100;
		if (a[i] < f(x1) || a[i] > f(x2))
		{
			cout << "No solution!" << endl;
			continue;
		}
		while (fabs(f(root) - a[i]) >= EPS)
		{
			if (f(root) - a[i] > 0)
			{
				x2 = root;
			}
			else
			{
				x1 = root;
			}
			root = x1 + (x2 - x1) / 2;
		}
		printf("%.4f\n", root);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值