题目背景
John的农场缺水了!!!
题目描述
Farmer John has decided to bring water to his N (1 <= N <= 300) pastures which are conveniently numbered 1…N. He may bring water to a pasture either by building a well in that pasture or connecting the pasture via a pipe to another pasture which already has water.
Digging a well in pasture i costs W_i (1 <= W_i <= 100,000).
Connecting pastures i and j with a pipe costs P_ij (1 <= P_ij <= 100,000; P_ij = P_ji; P_ii=0).
Determine the minimum amount Farmer John will have to pay to water all of his pastures.
POINTS: 400
农民John 决定将水引入到他的n(1<=n<=300)个牧场。他准备通过挖若
干井,并在各块田中修筑水道来连通各块田地以供水。在第i 号田中挖一口井需要花费W_i(1<=W_i<=100,000)元。连接i 号田与j 号田需要P_ij (1 <= P_ij <= 100,000 , P_ji=P_ij)元。
请求出农民John 需要为使所有农场都与有水的农场相连或拥有水井所需要的钱数。
输入输出格式
输入格式:
第1 行为一个整数n。
第2 到n+1 行每行一个整数,从上到下分别为W_1 到W_n。
第n+2 到2n+1 行为一个矩阵,表示需要的经费(P_ij)。
输出格式:
只有一行,为一个整数,表示所需要的钱数。
输入输出样例
输入样例#1:
4
5
4
4
3
0 2 2 2
2 0 3 3
2 3 0 4
2 3 4 0
输出样例#1: 复制
9
算法思路:还是最小生成树,但是是n+1个节点,要考虑打井的点
#include<stdio.h>
#include<algorithm>
using namespace std;
int n,m;
int w[305];
int p[305][305];
int Tree[305];
struct Edge
{
int from,to,cost;
bool operator<(const Edge &A) const
{
return cost<A.cost;
}
}edge[100000];
int findRoot(int x)
{
if(Tree[x]==-1)
return x;
else
return findRoot(Tree[x]);
}
int main()
{
int n,sum,cnt,i,j,a,b;
while(scanf("%d",&n),n)
{
for(i=0;i<=n;i++)
{
Tree[i]=-1;
}
m=1;
for(i=1;i<=n;i++)
{
scanf("%d",&w[i]);
edge[m].from=0;
edge[m].to=i;
edge[m].cost=w[i];
m++;
}
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
scanf("%d",&p[i][j]);
if(i<j)
{
edge[m].from=i;
edge[m].to=j;
edge[m].cost=p[i][j];
m++;
}
}
}
m--;
sort(edge+1,edge+1+m);
sum=0;
cnt=0;
for(i=1;i<=m;i++)
{
a=findRoot(edge[i].from);
b=findRoot(edge[i].to);
if(a!=b)
{
Tree[a]=b;
sum+=edge[i].cost;
cnt++;
}
if(cnt==n)
break;
}
printf("%d\n",sum);
}
return 0;
}