适合初步练习PAT乙级——(1028) 人口普查

适合初步练习PAT乙级——(1028) 人口普查

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。
这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。
输入格式:
输入在第一行给出正整数 N,取值在(0,105];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。
输出格式:
在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。
输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:
3 Tom John

#include<iostream>
#include<string>
using namespace std;
int main() {
	int n, cnt = 0;
	cin >> n;
	string name, birth, maxname, minname, maxbirth = "1814/09/06", minbirth = "2014/09/06";
	for (int i = 0; i < n; i++) {
		cin >> name >> birth;
		if (birth >= "1814/09/06"&&birth <="2014/09/06") {
			cnt++;
			if (birth >= maxbirth) {
				maxbirth = birth;
				maxname = name;
			}
			if (birth <= minbirth) {
				minbirth = birth;
				minname = name;
			}
		}
		
	}

	cout << cnt;
	if (cnt != 0)cout << " " << minname << " " << maxname;
	return 0;
}

要注意字符串的比较是基于ASCLL的计较,这里确保每个输入的日期都是合法的,但不一定是合理的,就给我们的启示,可用字符串来进行日期的比较。

方法2:

#include<cstdio>
struct person {
	char name[10]; //姓名gg
	int yy, mm, dd;//日期
}oldest,youngest,left,right,temp;
//oldest与youngest存放最年长和最年轻的人,left与right存放合法日期的左右边界

bool LessEqu(person a, person b) { //如果a的日期小于等于b,放回true
	if (a.yy != b.yy)return a.yy <= b.yy;
	else if (a.mm != b.mm)return a.mm <= b.mm;
	else return a.dd <= b.dd;

}
bool MoreEqu(person a, person b) { //如果a的日期大于等于b,放回true
	if (a.yy != b.yy)return a.yy >= b.yy;
	else if (a.mm != b.mm)return a.mm >= b.mm;
	else return a.dd >= b.dd;

}
//初始化最年长和最年轻
void init() {
	youngest.yy = left.yy = 1814;
	oldest.yy = right.yy = 2014;
	youngest.mm = oldest.mm = left.mm = right.mm = 9;
	youngest.dd = oldest.dd = left.dd = right.dd = 6;
}
int main() {
	init();
	int n, num = 0;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		scanf("%s %d/%d/%d", temp.name, &temp.yy, &temp.mm, &temp.dd);
		if (MoreEqu(temp, left) && LessEqu(temp, right)) {//日期合法
			num++;
			if (LessEqu(temp, oldest))oldest = temp;
			if (MoreEqu(temp, youngest))youngest = temp;
		}
	}
	if (num == 0)printf("0\n");
	else printf("%d %s %s\n", num, oldest.name, youngest.name);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值