Pie

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
—One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
—One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655
题目大意:
输入N,测试实例的个数,然后是n,m,分别为蛋糕的数量和人数,接着是每块蛋糕的半径,要将蛋糕分给没个人(包括他自己),输出每个人可以分到的最大面积。
思路:
这道题我们采用二分的策略来做题。首先我们将蛋糕的面积加和再除以人数为X,这是每个人可以分到的最大的面积(当然这是绝对不可能的,因为每个人只能分到一块),然后我们以l=0,r=X,之后就进行二分,二分结束的条件是(r-l)<1e-6,每次二分用每块蛋糕面积除以mid再加和,通过人数比较来决定mid应该向哪个方向移动。(不必担心这个蛋糕除以mid得到的人数,可能实际行不通,因为我们会二分很多次,通过不断地缩减范围来找到最终的最优解)
AC代码:

#include<stdio.h>
#include<iostream>
#include<stdlib.h>
#include<cstring>
#include<math.h>
#include<algorithm>
using namespace std;
const int N=1e5+10;
double a[N];
int n,m;
double pi=acos(-1.0);//圆周率更准确 
int check(double x)
{
	int num=0;
	for(int i=0;i<n;i++)
	{
		num+=int(a[i]/x);//num为当前面积可以分的人数 
	}
	if(num>=m)   //大于m满足要求 
	   return 1;
	else
	   return 0;
}
int main()
{
	double l,r,mid,v;
	int num;
	scanf("%d",&num);
	while(num--)
	{
		scanf("%d %d",&n,&m);
		m=m+1;
		for(int i=0;i<n;i++)
		{
			cin >> r;
			a[i]=r*r*pi;//a[N]记录每块蛋糕的面积 
			v=v+a[i];//v是蛋糕的总体积 
		}
		double max;
		sort(a,a+n);//二分必排序 
		max=v/m;
		l=0,r=max;
		while((r-l)>1e-6)
		{
			mid=(r+l)/2;
			if(check(mid))   l=mid;//满足要求的,mid向大的一方靠拢 
			else             r=mid;
		}
		printf("%.4lf\n",l);
	}
}
  • 3
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值