钱币兑换问题

钱币兑换问题(http://acm.hdu.edu.cn/showproblem.php?pid=1284)

Problem Description

在一个国家仅有1分,2分,3分硬币,将钱N兑换成硬币有很多种兑法。请你编程序计算出共有多少种兑法。

Input

每行只有一个正整数N,N小于32768。

Output

对应每个输入,输出兑换方法数。

Sample Input

2934
12553

Sample Output

718831
13137761

参考:https://blog.csdn.net/hj1553910/article/details/81488120

正确代码:

#include<iostream>
#include<cmath>
#define LL long long
using namespace std;
LL s[32769];
void dp(){
 s[0]=1;
 for(int j=1;j<=3;j++)
 for(int i=1;i<=32768;i++){
  s[i]+=s[i-j];
 }
}
int main(){
 int n; 
 dp();
 while(cin>>n){
  cout<<s[n]<<endl;
 }
 return 0;
}

错误代码(不晓得哪里错了)

#include<iostream>
#include<cstdio> 
#include<cmath>
using namespace std;
const int Max=33000;//注意Max的M大写 
int main()
{
   long long a[Max];
   a[0]=1;
   for(int i=1;i<=3;i++)  //用递归来做 
    {
    for(int j=i;j<=Max;j++){
     a[j]+=a[j-i]; 
    }
   }
   int n;
   while(cin>>n) {
    cout<<a[n]<<endl;//endl相当于转行的作用 
   }
 return 0;
}


换了种做法,错了,不知道拿错了,先放放

```c
#include<iostream>
#include<cstdio> 
#include<cmath>
using namespace std;
const int Max=32769;
int main()
{
   long long a[Max];
   a[0]=1;
   a[1]=1;
   a[2]=2;
   a[3]=3;
   for(int i=4;i<=Max;i++)
    {
    for(int j=1;j<=3;j++){
     a[i]+=a[i-j]; 
    }
   }
   int n;
   while(cin>>n) {
    cout<<a[n]<<endl;//endl相当于转行的作用 
   }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值