HDU-1069 Monkey and Banana

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n n n types of blocks, and an unlimited supply of blocks of each type. Each type- i i i block was a rectangular solid with linear dimensions ( x i , y i , z i x_i, y_i, z_i xi,yi,zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n n n, representing the number of different blocks in the following data set. The maximum value for n n n is 30 30 30.
Each of the next n n n lines contains three integers representing the values x i , y i x_i, y_i xi,yi and z i z_i zi.
Input is terminated by a value of zero (0) for n n n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1 1 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

Reference Code

#include<bits/stdc++.h>
using namespace std;
const int maxn=30+3;
struct block{
    int x,y,z;
    bool operator<(const block &oth)const{
        return x==oth.x?y>oth.y:x>oth.x;
    }
    bool operator>(const block &oth)const{
        return x>oth.x&&y>oth.y;
    }
};
vector<block> B;
void init(int x,int y,int z){
    B.push_back({x,y,z});
    B.push_back({x,z,y});
    B.push_back({y,x,z});
    B.push_back({y,z,x});
    B.push_back({z,y,x});
    B.push_back({z,x,y});
}
int solve(){
    sort(B.begin(),B.end());
    int dp[6*maxn],res=0;
    for(int i=0;i<B.size();i++){
        dp[i]=B[i].z;
        for(int j=0;j<i;j++)
            if (B[j]>B[i]) dp[i]=max(dp[i],dp[j]+B[i].z);
        res=max(res,dp[i]);
    }
    B.clear();
    return res;
}
int main(){
    int n,x,y,z,cnt=0;
    while (~scanf("%d",&n)&&n){
        for (int i=0;i<n;i++){
            scanf("%d%d%d",&x,&y,&z);
            init(x,y,z);
        }
        printf("Case %d: maximum height = %d\n",++cnt,solve());
    }
    return 0;
}

Tips

最优解问题,想到用DP解决。
首先,不难发现,每一个木块最多被用 6 6 6次,且每次的长宽高都不全一样。因此,我们可以把原先的 n n n个木块看成 6 n 6n 6n个新木块,每个新木块最多用一次。
然后,我们就可以根据长宽大小对这 6 n 6n 6n个新木块排序,长最长的在前,若长相同,宽最长的在前。假设排序后保存在block向量中。
现设定状态 d p [ i ] dp[i] dp[i],表示用前 i i i块木块可以达到的最大高度。则有 d p [ i ] = max ⁡ ( d p [ i ] , d p [ j ] + block [ i ] . z ) , dp[i]=\max(dp[i],dp[j]+\text{block}[i].z), dp[i]=max(dp[i],dp[j]+block[i].z),其中 1 ⩽ j ⩽ i − 1 1\leqslant j\leqslant i-1 1ji1(能不能搭上去需要判断)。边界条件为 d p [ i ] = block [ i ] . z dp[i]=\text{block}[i].z dp[i]=block[i].z其余见代码。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值