HDU-1084 What Is Your Grade?

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!

Input

Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.

Output

Output the scores of N students in N lines for each case, and there is a blank line after each case.

Sample Input

4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1

Sample Output

100
90
90
95

100

Reference Code

#include<bits/stdc++.h>
using namespace std;
const int maxn=100+3;
struct exam{
    int idx,p,t,rnk;
    exam(int idx=0,int p=0,int t=0):idx(idx),p(p),t(t){}
}a[maxn];
bool cmp1(const exam &x,const exam &y){
    return x.p!=y.p?x.p>y.p:x.t<y.t;
}
bool cmp2(const exam &x,const exam &y){
    return x.idx<y.idx;
}
int n,cnt[6];
int main(){
    while (~scanf("%d",&n),n>=0){
        memset(cnt,0,sizeof(cnt));
        for (int i=0;i<n;++i){
            int p,h,m,s;
            scanf("%d %d:%d:%d",&p,&h,&m,&s);
            a[i]={i,p,3600*h+60*m+s};
            ++cnt[p];
        }
        sort(a,a+n,cmp1);
        int pp=a[0].p,rnk=1;
        for (int i=0;i<n;++i){
            if (a[i].p<pp) rnk=1,pp=a[i].p;
            a[i].rnk=rnk++;
        }
        sort(a,a+n,cmp2);
        for (int i=0;i<n;++i){
            int mark=50+a[i].p*10;
            if (mark!=100&&mark!=50&&a[i].rnk<=cnt[a[i].p]/2)
                mark+=5;
            printf("%d\n",mark);
        }
        printf("\n");
    }
}

Tips

模拟题,读清题意并注意输出格式即可。
具体方法为,先按成绩排序,得到该同学在他的对应分数段里的排名;然后按序号排回来,便于输出。输出时根据排名确定是否要加5。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值