POJ--1502 MPI Maelstrom

最近在复习最短路径。
dijkstra和最小生成树等等这些图论算法确实折磨了我一段时间啊。。
理解了就感觉好多了,最主要的是熟练。
这题其实是个裸的最短路径题目。可以用dijkstra,floyd这些算法,floyd的主要思想我是这样理解的,两点之间不断找中转点,直到遍历所有点。floyd还是有标准的模板可以套的,三个循环套就可。
dijkstra相比较更难理解,更偏向于贪心的思想吧。
这里用一道POJ的题目练练手。
不得不说POJ的题目是厉害,很锻炼人,我认为对练习算法还是很有帮助。
这道题很长,读题要读很久啊,特别还是英文。读懂了就很简单了,很明显的最短路径题目,至于题目给的数据,可以理解为邻接矩阵matrix。x代表不能相连的两点,用inf代表。

MPI Maelstrom
Time Limit: 1000MS

Memory Limit: 10000K
Total Submissions: 13245

Accepted: 8159
Description
BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee’s research advisor, Jack Swigert, has asked her to benchmark the new system.
Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert.Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.’’

``How is Apollo’s port of the Message Passing Interface (MPI) working out?’’ Swigert asked.

Not so well,'' Valentine replied.To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.’’

``Is there anything you can do to fix that?’’

Yes,'' smiled Valentine.There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.’’

``Ah, so you can do the broadcast as a binary tree!’’

``Not really a binary tree – there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don’t necessarily arrive at the destinations at the same time – there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.’’
Input
The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.
Output
Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.
Sample Input
5
50
30 5
100 20 50
10 x x 10
Sample Output
35

题目大意就是从1到其他所有点找最短路径的最大值吧,注意x代表不可连接就行。
先将起点到其他所有点的路径求出,存放在dis数组里,再遍历一遍找最大值就ok。
找最大值的时候要注意inf的情况,以及要注意inf溢出的情况!
我才开始写的时候没有注意到inf溢出情况,导致错了一个下午,改了很久,可惜了。也可以把inf设的小一点。
这里我用dijkstra写的,贴出代码。

#include<stdio.h>
#include<string.h>
#define inf (~(0x1<<31)) 

int matrix[1010][1010];
int visited[1010];
int dis[1010];
int n;

void dijkstra(int x,int n,int *visited,int mat[1010][1010]) // 从x开始 
{	
	int i,j,k;
	for(i=1; i<=n; i++)
	{
		dis[i] = mat[x][i];
	}
	memset(visited,0,sizeof(visited));
	visited[x] = 1;
	for(i=1; i<n; i++)
	{
		int min = inf;
		int minj = -1;
		for(j=1; j<=n; j++)
		{
			if(visited[j])
				continue;
			if(min > dis[j])
			{
				min = dis[j];
				minj = j;
			}
		}
		if(minj == -1)
		continue;
		visited[minj] = 1;
		for(k=1; k<=n; k++)
		{
		    int t = (mat[minj][k] == inf)?inf:dis[minj] + mat[minj][k];//防止溢出 
		    if(t < dis[k] && !visited[j])
		    dis[k] = t;
		}
	}
 } 
 
 int main()
 {
 	int i,j;
 	scanf("%d",&n);
 	char str[100];
 	for(i=1; i<=n; i++)
 	{
 		for(j=1; j<=n; j++)
 		{
 			if(i == j)
 			{
 				matrix[i][j] = 0;
 				continue;
			 }
 			if(j > i)
 			break;
 			scanf("%s",str);
 			if(str[0] == 'x')
 				matrix[i][j] = matrix[j][i] = inf;
 			else
 				matrix[i][j] = matrix[j][i] = atoi(str);
	 	}
 	}
 
	 dijkstra(1,n,visited,matrix);
	 int max = 0;
	 for(i=1; i<=n; i++)
	 {
	 	if(max < dis[i] && dis[i] != inf)
	 	max = dis[i];
	 }
	 printf("%d",max);
	 return 0;
 }
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值