POJ2386 Lake Counting(dfs求连通块/%c与%s)

那一天我十九岁,在我一生的黄金时代,我有好多奢望。我想爱,想吃,还想在一瞬间变成天上半明半暗的云,后来我才知道,生活就是个缓慢受锤的过程,人一天天老下去,奢望也一天天消逝,最后变得像挨了锤的牛一样。可是我过二十一岁生日时没有预见到这一点。我觉得自己会永远生猛下去,什么也锤不了我。(什么时候结课啊,我要卒了)
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 48045 Accepted: 23606

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

  • Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12
W…WW.
.WWW…WWW
…WW…WW.
…WW.
…W…
…W…W…
.W.W…WW.
W.W.W…W.
.W.W…W.
…W…W.

Sample Output

3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Solution

见小白书第三十二页
看起来就是求连通块,也没什么五花六花(的诈骗)啊,为什么我一直RE呢?
看了一眼白书题解,哦,忘记先找气球再搜了+忘记将第一个W改成.了。改掉之后,美滋滋地提交,又RE了
再回去仔细看输入输出,原来%s不是读一个字符啊,%c才是
再改就过了。

丑陋的AC代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
char a[101][101];
int n,m;
int dx[8]={0,0,1,1,1,-1,-1,-1},dy[8]={1,-1,0,1,-1,0,1,-1};
void dfs(int x,int y)
{
    a[x][y]='.';
    for(int i=0;i<8;++i)
    {
        int xx=x+dx[i];
        int yy=y+dy[i];
        if(xx>=0&&xx<=n&&y>=0&&y<=m&&(a[xx][yy]=='W'))
        {
            dfs(xx,yy);
        }
    }
    return;
}
int main()
{
    int p=0;
    scanf("%d %d",&n,&m);
    for(int i=0;i<n;++i)
    {
        scanf("%s",a[i]);
    }
    for(int i=0;i<n;++i)
    {
        for(int j=0;j<m;++j)
        {
            //printf("%s",a[i][j]);
            if(a[i][j]=='W')
            {
                dfs(i,j);
                ++p;
            }
        }
    }
    printf("%d\n",p);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值