S-Nim (HDU 1536)组合博弈&SG多组游戏

S-Nim

题目链接

Problem Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

The players take turns chosing a heap and removing a positive number of beads from it.

The first player not able to make a move, loses.

Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:

Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

If the xor-sum is 0, too bad, you will lose.

Otherwise, move such that the xor-sum becomes 0. This is always possible.

It is quite easy to convince oneself that this works. Consider these facts:

The player that takes the last bead wins.

After the winning player’s last move the xor-sum will be 0.

The xor-sum will change after every move.

Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

Input

Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.

Output

For each position: If the described position is a winning position print a ‘W’.If the described position is a losing position print an ‘L’. Print a newline after each test case.

Sample Input:

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

Sample Output:

LWW
WWL

题目大意

题目看起来又长又臭,其实很简单。先输入一个k,然后跟着k个数,每个数代表着可以走的步数(可选步数为一系列不连续的数,用GetSG()计算类型的题目!!!)。接着输入一个m,代表在上面可走步数限制下,有几组测试数据,然后输入m组测试数据,每组第一个数 l 代表有几个堆,然后输入l个堆的石子数量。对于每组数据,求所有堆的sg值然后一起异或一下,如果为0,先手失败输出"L",如果不为0,先手获胜输出"W"。

解题思路

可选步数为不连续整数类型题目的进阶版(参考题解),这题难点在于容易getSG函数超时,解决方法是将mex数组的memset操作由n次变为1次,设置一个int类型的cnt来标记sg数组的更新操作。具体看代码理解。

AC代码

#include <bits/stdc++.h>
using namespace std;
#define max(a, b) ((a) > (b) ? (a) : (b))

const int MAXN = 10005;

int sg[MAXN],f[105],mex[MAXN],k;

void getsg(int n)
{
    int cnt=1;
    memset(sg, 0, sizeof(sg));
    memset(mex, 0, sizeof(mex));
    for(int i=1; i<=n; i++){
        for(int j=0; f[j]<=i&&j<k; j++){
            mex[sg[i-f[j]]] = cnt;
        }
        for(int j=0;;j++){
            if(mex[j]!=cnt){
                sg[i] = j;
                break;
            }
        }
        cnt++;
    }
}

int main(int argc, char **argv)
{
	//freopen("./input.txt","r",stdin);
    while(~scanf("%d",&k) && k){
        for(int i=0; i<k; i++){
            scanf("%d",&f[i]);
        }
        sort(f,f+k);
        getsg(10000);
        int m,l,h;
        scanf("%d",&m);
        while(m--){
            int ans=0;
            scanf("%d",&l);
            while(l--){
                scanf("%d",&h);
                ans^=sg[h];
            }
            if(ans){
                printf("W");
            }else{
                printf("L");
            }
        }
        printf("\n");
    }
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值