【剑指紫金港】1095 Cars on Campus 模拟

A 1095 Cars on Campus

题目链接

Problem Description

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input

Each input file contains one test case. Each case starts with two positive integers N (≤10​4​​ ), the number of records, and K (≤8×10​4​​ ) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_numberis a string of 7 English capital letters or 1-digit numbers; hh:mm:ssrepresents the time point in a day by hour:minute:second, with the earliest time being 00:00:00and the latest 23:59:59; and statusis either inor out.

Note that all times will be within a single day. Each inrecord is paired with the chronologically next record for the same car provided it is an outrecord. Any inrecords that are not paired with an outrecord are ignored, as are outrecords not paired with an inrecord. It is guaranteed that at least one car is well paired in the input, and no car is both inand outat the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

题目大意

输入一个停车场一天的车辆进出记录,求出某个查询时间点停车场里车辆的数量,以及这一天停车时间最长的车的车牌号,如果时间最长有多辆车,按照车牌号字典序从小到大输出。同一个车牌号的记录,按时间先后排列,对于每一个in,如果它后面第一个记录是out则配对,是一个有效记录,否则抛弃,out同理。

解题思路

将时间转化成24(时)*60(分)*60(秒),先确定每辆车的每一对有效记录,然后更新每个时间点车辆变化情况(t数组),t数组累加结果就是每个时间点的车辆数。依次求出每辆车的停车时间,得出停车时间最长的车牌号集合。

AC代码

#include <bits/stdc++.h>
using namespace std;
#define max(a, b) ((a) > (b) ? (a) : (b))
#define INF 0x3f3f3f3f
typedef long long ll;

const int maxn = 24*60*60;

int t[maxn],n,k,h,m,s,car,ind=0,maxtime=0;
string plate,status;
unordered_map<string, int> idHash;
vector<string>ans;
vector<pair<string, int>> record[10005];

bool cmp(pair<string, int> &a, pair<string, int> &b){
	return a.second<b.second;
}

int main(int argc, char **argv){
	fill(t, t+maxn, 0);
	scanf("%d%d",&n,&k);
	while(n--){
		cin>>plate;
		scanf("%d:%d:%d",&h,&m,&s);
		cin>>status;
		car=h*3600+m*60+s;
		if(idHash.find(plate)!=idHash.end()){
			int d=idHash[plate];
			record[d].emplace_back(status,car);
		}else{
			int d=ind;
			idHash[plate]=ind++;
			record[d].emplace_back(status,car);
		}
	}
	for(auto it=idHash.begin(); it!=idHash.end(); it++){
		int id=it->second;
		int last=0;
		sort(record[id].begin(), record[id].end(), cmp);
		for(int i=0,limit=record[id].size()-1; i<limit;){
			if(record[id][i].first=="in"){
				if(record[id][i+1].first=="out"){
					int inn=record[id][i].second;
					int outt=record[id][i+1].second;
					last+=outt-inn;
					t[outt]--;
					t[inn]++;
					i+=2;
				}else{
					i++;
				}
			}else{
				i++;
			}
		}
		if(last>maxtime){
			maxtime=last;
			ans.clear();
			ans.emplace_back(it->first);
		}else if(last==maxtime){
			ans.emplace_back(it->first);
		}
	}
	sort(ans.begin(),ans.end());
	for(int i=1; i<maxn; i++){
		t[i]+=t[i-1];
	}
	while(k--){
		scanf("%d:%d:%d",&h,&m,&s);
		car=h*3600+m*60+s;
		printf("%d\n",t[car]);
	}
	for(int i=0; i<ans.size(); i++){
		cout<<ans[i]<<" ";
	}
	int hour=maxtime/3600;
	int minute=(maxtime-hour*3600)/60;
	int ss=maxtime-hour*3600-minute*60;
	printf("%02d:%02d:%02d",hour,minute,ss);
    return 0;
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值