【剑指紫金港】1086 Tree Traversals Again 已知先序中序求后序

A 1086 Tree Traversals Again

题目链接

Problem Description

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
figure1

Input

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题目大意

给出一段栈模拟命令,出栈顺序就是一颗二叉树的中序序列。输出这颗二叉树的后序序列。

解题思路

得到隐藏条件——入栈顺序是一颗二叉树的先序序列,然后根据这两个序列找到所有根节点及其对应的左右子树,将根节点放在左右子树后面输出,就得到后序序列了。

AC代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 35;

int in[maxn],pre[maxn],n,m,node,ind=0,pnd=0,cnt=0;
string str;
stack<int>stk;

void dfs(int inL,int inR,int preL,int preR){
    if(preL>preR) return;
    int root=pre[preL],k;
    for(;k<inR;k++){
        if(in[k]==root) break;
    }
    int leftnum=k-inL;
    dfs(inL,k-1,preL+1,preL+leftnum);
    dfs(k+1,inR,preL+leftnum+1,preR);
    if(cnt==0){
        printf("%d",root);
        cnt++;
    }else{
        printf(" %d",root);
        cnt++;
    }
    return;
}

int main(){
    scanf("%d",&n);
    m=2*n;
    while(m--){
        cin>>str;
        if(str=="Push"){
            cin>>node;
            stk.push(node);
            pre[pnd++]=node;
        }else{
            in[ind++]=stk.top();
            stk.pop();
        }
    }
    dfs(0,n-1,0,n-1);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值