Codeforces Round #550 (Div. 3) E. Median Stringl

You are given two strings s and t, both consisting of exactly k lowercase Latin letters, s is lexicographically less than t.

Let’s consider list of all strings consisting of exactly k lowercase Latin letters, lexicographically not less than s and not greater than t (including s and t) in lexicographical order. For example, for k=2, s=“az” and t=“bf” the list will be [“az”, “ba”, “bb”, “bc”, “bd”, “be”, “bf”].

Your task is to print the median (the middle element) of this list. For the example above this will be “bc”.

It is guaranteed that there is an odd number of strings lexicographically not less than s and not greater than t.

Input
The first line of the input contains one integer k (1≤k≤2*10^5) — the length of strings.

The second line of the input contains one string s consisting of exactly k lowercase Latin letters.

The third line of the input contains one string t consisting of exactly k lowercase Latin letters.

It is guaranteed that s is lexicographically less than t.

It is guaranteed that there is an odd number of strings lexicographically not less than s and not greater than t.

Output
Print one string consisting exactly of k lowercase Latin letters — the median (the middle element) of list of strings of length k lexicographically not less than s and not greater than t.

SampleInput 1
2
az
bf
SampleOutput 1
bc
SampleInput 2
5
afogk
asdji
SampleOutput 2
alvuw
SampleInput 3
6
nijfvj
tvqhwp
SampleOutput 3
qoztvz

题意就是输入一个长度n 然后输入两个长度为n的字符串 一个是s 一个是t s的字典序一定小于等于t
然后让求中间的那个串
其实这题就是模拟一下26进制 两个字符串 就是两个数 我们要求中间串 也就是求这两个数的和的二分之一 那么我们只要模拟一个26进制的加法就可以了

#include<bits/stdc++.h>
using namespace std;
int k;
int q[200005],w[200005];
char s[200005],t[200005];
int main(){

   cin>>k>>s>>t;
   for(int i=0;i<k;i++)
    q[k-1-i]=s[i]-'a',w[k-1-i]=t[i]-'a';

   for(int i=0;i<k;i++)
   {
       q[i]+=w[i];
       if(q[i]>=26)
       {
           q[i+1]+=1;
           q[i]%=26;
       }
   }
   if(q[k]) q[k-1]+=26;
   for(int i=k-1;i>=0;i--)
   {
       if(q[i]&1)
       {
           q[i-1]+=26;
       }
       q[i]/=2;
       printf("%c",'a'+q[i]);
   }
  return 0;
}
``

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我不会c语言

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值