HDU 5210

WLD likes playing with numbers. One day he is playing with N integers. He wants to delete K integers from them. He likes diversity, so he wants to keep the kinds of different integers as many as possible after the deletion. But he is busy pushing, can you help him?
input
There are Multiple Cases. (At MOST 100100)
For each case:
The first line contains one integer N(0<N≤100)N(0<N≤100).
The second line contains NN integers a1,a2,…,aN(1≤ai≤N)a1,a2,…,aN(1≤ai≤N), denoting the integers WLD plays with.
The third line contains one integer K(0≤K<N)K(0≤K<N).

output
For each case:
Print one integer. It denotes the maximum of different numbers remain after the deletion.

Sample Input

4
1 3 1 2 
1

Sample Output

3

Hint
if WLD deletes a 3, the numbers remain is [1,1,2],he’ll get 2 different numbers.
if WLD deletes a 2, the numbers remain is [1,1,3],he’ll get 2 different numbers.
if WLD deletes a 1, the numbers remain is [1,2,3],he’ll get 3 different numbers.

AC代码:

#include <stdio.h>
#include <string>
#include <stdlib.h>
#include <math.h>
#include <map>
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        map<int,int> mp;
        int maxx=0;
        int kind=0,kind2=0;
        for(int i=0; i<n; i++)
        {
            int x;
            scanf("%d",&x);
            if(mp[x]==0)
            {
                kind++;
                mp[x]++;
            }
            else
                kind2++;
        }
        int del;
        scanf("%d",&del);
        if(del<kind2)
            maxx=kind;
        else
            maxx=kind+kind2-del;
        printf("%d\n",maxx);
    }
    return 0;
}

我觉得这道题题意很有问题。。是我太菜了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值