poj 3262 protect the flowers

Describe
Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.
Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.
Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.
Input
Line 1: A single integer N
Lines 2… N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow’s characteristics
Output
Line 1: A single integer that is the minimum number of destroyed flowers
Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint
In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.
In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题意:
老农一出门牛就不吃草了,改吃老农的宝贝花花了,老农要送牛回牛棚让自己的宝贝花花损失最少,每头牛送走的时间是t,来回就是2t,每只牛单位时间内吃dis朵花,求老农送牛使得宝贝花花的损失最少的最少数量是多少
思路:
(牛送走的时间/牛吃花的速度)从小到大 排序或者 (牛吃花的速度/牛送走的时间)从大到小来排序

(结构体用cmp真的好好用鸭)
AC代码:

#include <stdio.h>
#include <string>
#include <stdlib.h>
#include <math.h>
#include <map>
#include <stack>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
const int N=1e5+100;
struct node
{
    ll ti,dis;
}cow[100100];
bool cmp(node a,node b)
{
    return (a.ti*1.0/a.dis*1.0)<(b.ti*1.0/b.dis*1.0);
}
int main()
{
    int n;
    scanf("%d",&n);
    ll sumd=0;
    for(int i=0;i<n;i++)
    {
        scanf("%I64d%I64d",&cow[i].ti,&cow[i].dis);
        sumd+=cow[i].dis;
    }
    //printf("ok\n");
    sort(cow,cow+n,cmp);
    //printf("ok2\n");
    ll sum=0;
    //sumd=sumd-cow[0].dis;
    ll sumt=cow[0].ti*2;
    for(int i=1;i<n;i++)
    {
        sumt=cow[i-1].ti*2;
        sumd-=cow[i-1].dis;
       // printf("%I64d\n",sum+sumt*sumd);
        sum=sum+sumt*sumd;
    }
    printf("%I64d\n",sum);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值