poj 3069 Saruman‘s Army

Description
Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input
The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output
For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint
In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.
In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题意:
某种叫palantir的东西有一个范围r,然后有n个军队在各自位置(位置可以相同),问用多少个palantir可以把所有的军队全部覆盖
(类似于poj1328 Radar Installation)
思路:
把军队所有位置sort排序,从左到右遍历,如果不能包含就加一个palantir
(叠加palantir的时候写得我怀疑人生,我一直按poj1328的写法来写,还用了结构体左右点。。我太菜了吧也!!一到模拟就有问题。。代码能力实在太弱,还是csdn了一下才知道怎么写的,所以我自己的代码有点复杂,不需要用结构体)

AC代码:

///DO NOT ANGRY.
///JUST CALM DOWN AND TAKE IT EASY.
///ENJOY & FOCUS ON CODING.
///:)
#include <stdio.h>
#include <string>
#include <stdlib.h>
#include <math.h>
#include <map>
#include <stack>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
struct node
{
    ll location;
    ll l,r;
}army[1314];
bool cmp(node a,node b)
{
    return a.location<b.location;
}
int main()
{
    ll ran,n;
    while(~scanf("%I64d%I64d",&ran,&n))
    {
        if(ran==-1&&n==-1)break;
        for(int i=0;i<n;i++)
        {
            scanf("%I64d",&army[i].location);
            army[i].l=army[i].location-ran;
            army[i].r=army[i].location+ran;
        }
        sort(army,army+n,cmp);
        ll plantir;
        ll sum=0;
        ///以下这一段就是我搞出来的不知名的垃圾。。
        /*
        ll sum=1;
        for(int i=1;i<n;i++)
        {
            if(army[i].l>plantir+ran)
            {
                //printf("i=%d,plantir=%I64d,army.l=%I64d\n",i,plantir,army[i].l);
                sum++;
                plantir=army[i].location;
            }
            else if(army[i].r>plantir+ran)
            {
                plantir=army[i].location;
            }
        }*/ 
        int i=0;
        while(i<n)
        {
            ll k=army[i].location;
            i++;
            while(i<n&&army[i].location<=k+ran)
            {
                i++;
            }
            plantir=army[i-1].location;
            while(i<n&&army[i].location<=plantir+ran)
            {
                i++;
            }
            sum++;
        }
        printf("%I64d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值