PAT----A1106 Lowest Price in Supply Chain (25point(s))

A1106 Lowest Price in Supply Chain (25point(s))

题意:
寻找最小深度的叶子节点并统计个数
Sample Input

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output

1.8362 2
#include"bits/stdc++.h"
using namespace std;
struct Node {
	vector<int> links;
};
const int maxn = 100005;
Node nodes[maxn];
int ans_depth = INT32_MAX;
int ans_cnt = 0;
void dfs(int id,int depth){
	if(nodes[id].links.empty()) {
		if(depth < ans_depth){
			ans_depth = depth;
			ans_cnt = 1;
		}else if(depth == ans_depth)
			ans_cnt ++;
	}
	for(int t:nodes[id].links)
		dfs(t,depth+1);
}
int main() {
	//freopen("input.txt","r",stdin);
	int n;
	double p,r;
	cin >> n >> p >> r;
	r /= 100;
	r += 1;
	
	for(int i=0; i<n; i++) {
		int k;  scanf("%d",&k);
		for(int j=0; j<k; j++) {
			int t; scanf("%d",&t);
			nodes[i].links.push_back(t);
		}
	}
	dfs(0,0);
	double ans = p*pow(r,ans_depth);
	printf("%.4f %d\n",ans,ans_cnt);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值