PAT----A1069 The Black Hole of Numbers (20point(s))

A1069 The Black Hole of Numbers (20point(s))

题意

如果一个数是0或者6174则这个数掉进了数字黑洞。输入一个数,按四位数的格式递减排序后的数字减去递增排序后的数字得到一个新的数,如此反复直至该数等于0或6174.

思路
总结

Sample Input:1

6767

Sample Output1

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input2:

2222

Sample Output2:

2222 - 2222 = 0000
#include"bits/stdc++.h"
using namespace std;
void toList(int x,int *a) {
	int i = 0;
	while(x) {
		a[i++] = x%10;
		x /= 10;
	}
}
int getNum(int *a,int n) {
	int res = 0;
	for(int i=0; i<n; i++) {
		if(i) res *= 10;
		res += a[i];
	}
	return res;
}
int main() {
	// freopen("input.txt","r",stdin);
	int x;
	cin >> x;
	int a[4] = {0};
	toList(x,a);
	while(true) {
		sort(a,a+4);
		int t1 = getNum(a,4);
		reverse(a,a+4);
		int t2 = getNum(a,4);
		x = t2 - t1;
		toList(x,a);
		printf("%04d - %04d = %04d\n",t2,t1,x);
		if(x == 6174 || x == 0)
			break;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值