PAT----A1070 Mooncake (25point(s))

A1070 Mooncake (25point(s))

题意

给出N中月饼的数量和总的价格,市场需求量,求最大利润

思路

简单贪心。

总结

数量和价格都有可能是浮点型,虽然数量在样例是整形。
Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

#include"bits/stdc++.h"
using namespace std;
struct Node{
	double p;
	double amount;
};
int main(){
	// freopen("input.txt","r",stdin);
	int n; double d; cin >> n >> d;
	Node nodes[n];
	for(int i=0;i<n;i++){
		scanf("%lf",&nodes[i].amount);
	}
	for(int i=0;i<n;i++){
		double p; scanf("%lf",&p);
		nodes[i].p = p/nodes[i].amount;
	}
	sort(nodes,nodes+n,[](Node& t1,Node& t2){
		return t1.p > t2.p;	
	});
	double ans = 0;
	for(Node &t:nodes){
		if(d == 0) break;
		int buy = min(d,t.amount);
		ans += buy*t.p;
		d -= buy;
	}
	printf("%.2f\n",ans);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值