PAT---A1112 Stucked Keyboard (20分)

题意

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.
键盘上的坏掉的键按下一次会输出k个对应的字符,给出一串键盘输出的字符串,找出坏掉的键,并输出原本的字符串。

思路

计数判断。最后一个字符要单独处理。注意坏掉的键要按照在字符串中的顺序输出,而不是按照升序输出,就是因为这个没注意折腾了2个小时,所以不看题目有时候会翻车。

Sample Input

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest
#include "bits/stdc++.h"
using namespace std;
int main(){
//     freopen("input.txt","r",stdin);
    int k; cin >> k;
    string s; cin >> s;
    map<char,bool> stucked;
    int cnt = 1;
    for (int i = 1; i < s.size(); ++i) {
        if (s[i] == s[i-1]) {
            cnt ++;
            if (cnt % k == 0){
                if (!stucked.count(s[i])) stucked[s[i]] = true;
            }
        } else  {
            if ( cnt % k) stucked[s[i-1]] = false;
            cnt = 1;
        }
        if(i == s.size() - 1 && (cnt % k) ) stucked[s[i]] = false;
    }

    map<char,int > _map;
    for(char e:s) if (stucked[e] && !_map[e]) _map[e] = 1, printf("%c",e);
    printf("\n");
    for (int i = 0; i < s.size(); ++i) {
        printf("%c",s[i]);
        if(stucked[s[i]]) i += k-1;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值