Friends (数组模拟大数乘)

28 篇文章 0 订阅
12 篇文章 0 订阅

Mike has many friends. Here are nine of them: Alice, Bob, Carol, Dave, Eve, Frank, Gloria, Henry and Irene. 

Mike is so skillful that he can master nn languages (aka. programming languages). 

His nine friends are all weaker than he. The sets they can master are all subsets of Mike's languages. 

But the relations between the nine friends is very complex. Here are some clues. 

1. Alice is a nice girl, so her subset is a superset of Bob's. 
2. Bob is a naughty boy, so his subset is a superset of Carol's. 
3. Dave is a handsome boy, so his subset is a superset of Eve's. 
4. Eve is an evil girl, so her subset is a superset of Frank's. 
5. Gloria is a cute girl, so her subset is a superset of Henry's. 
6. Henry is a tall boy, so his subset is a superset of Irene's. 
7. Alice is a nice girl, so her subset is a superset of Eve's. 
8. Eve is an evil girl, so her subset is a superset of Carol's. 
9. Dave is a handsome boy, so his subset is a superset of Gloria's. 
10. Gloria is a cute girl, so her subset is a superset of Frank's. 
11. Gloria is a cute girl, so her subset is a superset of Bob's. 

Now Mike wants to know, how many situations there might be. 

Input

The first line contains an integer TT(T≤20T≤20) denoting the number of test cases. 

For each test case, the first line contains an integer nn(0≤n≤30000≤n≤3000), denoting the number of languages.
 

Output

For each test case, output ''Case #t:'' to represent this is the t-th case. And then output the answer. 

Sample Input

2
0
2

Sample Output

Case #1: 1
Case #2: 1024
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int s = 100;
int num[3050];
int len;
int main()
{
    ios::sync_with_stdio(false);
    int t;
    int k = 0;
    cin >> t;
    memset(num, 0, sizeof(num));
    while(t--)
    {
       k++;
       int n;
       cin >> n;
       num[1] = 1;
       len = 1;
       for(int i=1;i<=n;i++)
       {
          int c = 0;
          for(int j=1;j<=len;j++)
          {
             num[j] *= 32;
             num[j] += c;
             c = num[j]/s;
             num[j] %= s;
          }
          while(c!=0)
          {
             num[++len] = c%s;
             c /=s;
          }
       }
       cout << "Case #" << k << ": ";
       for(int i=len;i>0;i--)
       {
           if(i!=len) printf("%02d", num[i]);
           else printf("%d", num[i]);
       }
       cout << endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值