K - Keywords Search(AC自动机1)

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc. 
Wiskey also wants to bring this feature to his image retrieval system. 
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched. 
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match. 

Input

First line will contain one integer means how many cases will follow by. 
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000) 
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50. 
The last line is the description, and the length will be not longer than 1000000. 

Output

Print how many keywords are contained in the description.

Sample Input

1
5
she
he
say
shr
her
yasherhs

Sample Output

3

题目大意:在文本串里面有多少个模式串

思路概括:裸的ac自动机模板题

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<bitset>
#include<cassert>
#include<cctype>
#include<cmath>
#include<cstdlib>
#include<ctime>
#include<deque>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
using namespace std;
typedef long long ll;
const double pi = acos(-1.0);
const ll mod = 1e9 + 7;
const int inf = 0x3f3f3f3f;
const int maxn = 1e6 + 5;
int trie[maxn][26];//字典树
int fail[maxn];//指针
int cntword[maxn];//记录单词出现次数
int cnt = 0;
void insertword(string str)//建立字典树
{
    int root = 0;
    for(int i=0;i<str.size();i++)
    {
        int now = str[i] - 'a';
        if(!trie[root][now])
        {
            trie[root][now] = ++cnt;
        }
        root = trie[root][now];
    }
    cntword[root]++;
}
void getfail()
{
    queue<int> q;
    for(int i=0;i<26;i++)//压入与根节点相连并存在的第一层节点
    {
        if(trie[0][i])
        {
            fail[trie[0][i]] = 0;//节点的指针指向根
            q.push(trie[0][i]);
        }
    }
    while(!q.empty())//分别跑他们的儿子
    {
        int now = q.front();
        q.pop();
        for(int i=0;i<26;i++)
        {
            if(trie[now][i])
            {
                fail[trie[now][i]] = trie[fail[now]][i];//该节点的指针指向父亲的指针所指向的节点的儿子
                q.push(trie[now][i]);
            }
            else trie[now][i] = trie[fail[now]][i];

        }
    }
}
int query(string str)
{
    int now = 0, ans = 0;
    for(int i=0;i<str.size();i++)
    {
        now = trie[now][str[i] - 'a'];
        for(int j=now; j && cntword[j] != -1 ;j = fail[j])//两个终止匹配的条件
        {
            ans += cntword[j];
            cntword[j] = -1;//标记已经跑过的节点
        }
    }
    return ans;
}
int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin >> t;
    while(t--)
    {
        memset(trie, 0, sizeof(trie));
        memset(fail, 0, sizeof(fail));
        memset(cntword, 0, sizeof(cntword));
        int n;
        cin >> n;
        string str;
        for(int i=0;i<n;i++)
        {
            cin >> str;
            insertword(str);//传模式串建立字典树
        }
        fail[0] = 0;//根的指针指向自己
        getfail();//给字典树建立指针
        str.clear();
        cin >> str;
        cout << query(str) << endl;//查询结果
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值