数的全排列问题---算法集

问题描述
将 n 个数字 1,2,…n 的所有排列按字典顺序枚举出猴
输入:
n
输出:
1 2 3
1 3 2
2 3 1
2 1 3
3 1 2
3 2 1

#include <iostream>
#include <algorithm>
using namespace std;
int main ()
{
	int n;
    cin>>n;
    int arr[n];
	for(int i=1;i<=n;i++)
	    arr[i-1]=i;
    do{
    	for(int i=0;i<n;i++)
            cout<<arr[i]<<" ";
        cout<<endl;
    }while(next_permutation(arr,arr+n));
    return 0;
}

问题描述
有4个互不相同的数字,输出由其中三个不重复数字组成的排列。

输入:
4个整数。

输出:
所有排列。

样例输入
1 2 3 4

样例输出
1 2 3
1 3 2
2 1 3
2 3 1
3 1 2
3 2 1
1 2 4
1 4 2
2 1 4
2 4 1
4 1 2
4 2 1
1 3 4
1 4 3
3 1 4
3 4 1
4 1 3
4 3 1
2 3 4
2 4 3
3 2 4
3 4 2
4 2 3
4 3 2

#include<bits/stdc++.h>
using namespace std;

int main(){
	int a[4];
	cin>>a[0]>>a[1]>>a[2]>>a[3];
	sort(a,a+4);
	int b[3]={a[0],a[1],a[2]};
    int c[3]={a[0],a[1],a[3]};
    int d[3]={a[0],a[2],a[3]};
    int e[3]={a[1],a[2],a[3]};
	do{
		cout<<b[0]<<" "<<b[1]<<" "<<b[2]<<endl;
	}while(next_permutation(b,b+3));
	do{
		cout<<c[0]<<" "<<c[1]<<" "<<c[2]<<endl;
	}while(next_permutation(c,c+3));
	do{
		cout<<d[0]<<" "<<d[1]<<" "<<d[2]<<endl;
	}while(next_permutation(d,d+3));
	do{
		cout<<e[0]<<" "<<e[1]<<" "<<e[2]<<endl;
	}while(next_permutation(e,e+3));
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值