Children's Game uva 10905

1 篇文章 0 订阅

There are lots of number games for children. These games are pretty easy to play but not so easy to make. We will discuss about an interesting game here. Each player will be given N positive integer. (S)He can make a big integer by appending those integers after one another. Such as if there are 4 integers as 123, 124, 56, 90 then the following integers can be made — 1231245690, 1241235690, 5612312490, 9012312456, 9056124123, etc. In fact 24 such integers can be made. But one thing is sure that 9056124123 is the largest possible integer which can be made. You may think that it’s very easy to find out the answer but will it be easy for a child who has just got the idea of number?

Input

Each input starts with a positive integer N (≤ 50). In next lines there are N positive integers. Input is terminated by N = 0, which should not be processed.

Output

For each input set, you have to print the largest possible integer which can be made by appending all the N integers.

Sample Input

4

123 124 56 90

5

123 124 56 90 9

5

9 9 9 9 9

0

Sample Output

9056124123

99056124123

99999

题意 & 思路:题目很水,将 n 个数拼成一个能拼的最大整数,但是不知道为啥,不管是用两个数模拟,还是自己手写字符串挨个模拟都会WA,用String却莫名过了?

#include<iostream>
 #include<map>
  #include<vector>
   #include<cstdio>
    #include<algorithm>
 using namespace std;
  typedef long long ll;
   typedef vector<ll> vl;
    typedef vector<int> vi;
     typedef vector<string> vs;
     typedef pair<int,int> pii;
      typedef pair<int,ll> pil;
       typedef pair<ll,int> pli;
        typedef pair<ll,ll> pll;
bool cmp(string a , string b){
   return a + b > b + a;
}
  int main(){      std::ios::sync_with_stdio(false);
            int n;
             vector<string> ans;
          while(cin >> n && n){   vs a;for(int i = 0 ; i < n ; ++ i){string k;cin >> k;a.push_back(k);}
              sort(a.begin(),a.end(),cmp);
              for(string i : a) cout << i;
              cout << endl;
          }
       }

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值