D-To begin or not to begin【思维题·暑假训练赛5】

Description

A box contains black balls and a single red ball. Alice and Bob draw balls from this box without replacement, alternating after each draws until the red ball is drawn. The game is won by the player who happens to draw the single red ball. Bob is a gentleman and offers Alice the choice of whether she wants to start or not. Alice has a hunch that she might be better off if she starts; after all, she might succeed in the first draw. On the other hand, if her first draw yields a black ball, then Bob’s chances to draw the red ball in his first draw are increased, because then one black ball is already removed from the box. How should Alice decide in order to maximize her probability of winning? Help Alice with decision.

Input

Multiple test cases (number of test cases≤50), process till end of input.
For each case, a positive integer k (1≤k≤10^5) is given on a single line.

Output

For each case, output:
1, if the player who starts drawing has an advantage
2, if the player who starts drawing has a disadvantage
0, if Alice’s and Bob’s chances are equal, no matter who starts drawing
on a single line.

Sample Input

1
2

Sample Output

0
1

Code

/*
start:序号1  另一名标为序号2
当黑球为奇数,如3(黑球)+1(红球)
1  2  1  2
红
黑 红
黑 黑 红
黑 黑 黑 红
赢的机会相同

同理,经过枚举,黑球为偶数时(如4),先开始的赢的机会大
1  2  1  2  1
红
黑 红
黑 黑 红
黑 黑 黑 红
黑 黑 黑 黑 红
*/
#include <iostream>
#include <cstdio>
using namespace std;

int main(){
    int k;
    while(~scanf("%d",&k)){
        if(k%2==0){
            cout <<'1'<< endl;
        }
        else cout <<'0'<< endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值