后缀表达式求值

描述
输入一个后缀表达式,计算它的值。操作数和操作码之间都以空格分开。
输入
一行,后缀表达式
输出
一行,一个整数,为后缀表达式的值
样例输入
16 9 4 3 + * -
样例输出
-47

#include<iostream>
#include<stack>
#define N 110
using namespace std;

int main()
{
    string str;
    stack<int> s;
    int n1,n2,top=0;
    while(cin>>str)
    {
        if(str=="+")
        {
            n1=s.top();
            s.pop();
            n2=s.top();
            s.pop();
            if(s.empty())
            {
                cout<<n2+n1;
                break;
            }
            s.push(n2+n1);
        }
        else if(str=="-")
        {
            n1=s.top();
            s.pop();
            n2=s.top();
            s.pop();
            if(s.empty())
            {
                cout<<n2-n1;
                break;
            }
            s.push(n2-n1);
        }
        else if(str=="/")
        {
            n1=s.top();
            s.pop();
            n2=s.top();
            s.pop();
            if(s.empty())
            {
                cout<<n2/n1;
                break;
            }
            s.push(n2/n1);
        }
        else if(str=="*")
        {
            n1=s.top();
            s.pop();
            n2=s.top();
            s.pop();
            if(s.empty())
            {
                cout<<n2*n1;
                break;
            }
            s.push(n2*n1);
        }
        else
        {
            int num=0;
            for(int i=0;i<str.size();i++)
            {
                num*=10;
                num+=str[i]-'0';
            }
            s.push(num);
        }
    }
    return 0;
}
  • 0
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值