拓扑排序

题目链接:
https://vjudge.net/contest/276133#problem/O
题目:
John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is
only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing
two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the
number of direct precedence relations between tasks. After this, there will be m lines with two integers
i and j, representing the fact that task i must be executed before task j.
An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3

题目说明:
一个数字的优先级大于另一个数字,我们需要将他们排序。第一行输入所需排序的数字和有几个优先级。(一定会有序列)
输出排序后的序列。

每一个点都有入度和出度,当一个点的入度为0时,说明它可能是第一个要执行的,将它放入队列中进行循环.代码有说明;一定有解不用考虑无解的情况.
代码:

#include <iostream>
#include <cstring>
#include <queue>
#include <cstdio>
using namespace std;
int n, m, dp[300][300], vis[300], ans[300];//ans储存结果 vis储存入度
int main()
{
	while(cin >> n >> m)
	{
		if(n == 0 && m == 0) break;//[b]注意:[/b]不是一个为0就结束而是两个都必须为0才结束
		int a, b;
		for(int i = 1; i <= m; i++)
		{
			cin >> a >> b;
			dp[a][b] = 1;
			vis[b]++;
		}
		queue <int> h;
		for(int i = 1; i <= n; i++)
		{
			if(!vis[i]) h.push(i);//如果他的入度为0,进入队列
		}
		int q = 0;
		while(!h.empty())//判断是否为空,是空就结束
		{
			int u = h.front();
			h.pop();
			ans[++q] = u;
			for(int i = 1; i <= n; i++)
			{
				if(dp[u][i])//将那个入度为0的删除,并将通过它入度的数减一,往复循环即可.
				{
					if(--vis[i] == 0)
					{
						h.push(i);
					}
				}
			}
		}
		for(int i = 1; i <= n; i++)
		{
			printf("%d%s", ans[i], i == n? "\n" : " ");
		}
		memset(ans, 0, sizeof(ans));
		memset(dp, 0, sizeof(dp));
		memset(vis, 0, sizeof(vis));
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值