B - You are my brother

Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.

Input

There are multiple test cases. 
For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2. 
Proceed to the end of file.

Output

For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.

Sample Input

5
1 3
2 4
3 5
4 6
5 6
6
1 3
2 4
3 5
4 6
5 7
6 7

Sample Output

You are my elder
You are my brother

Hint

小A最近结识了一个新朋友,小B。有一天,他们意识到他们是500年前的一家人。现在,小A想知道小B是他的哥哥,弟弟还是弟弟。              

输入              

有多个测试用例。              

对于每个测试用例,第一行有一个整数n(n<=1000)。接下来的n行有两个整数a和b(1<=a,b<=2000),表示b是a的父亲。当然,一个人只有一个父亲。小A是1,小B是2。继续到文件结尾。            

输出

对于每个测试用例,如果小B比小A年轻,请打印“You are my younger”。否则,如果小B是小A的长者,打印“你是我的长者”。否则,打印“你是我的兄弟”。每个测试用例的输出只占用一行。 

本来是想用并查集做,然后权值为1,结果实现不了,可能是我太菜了,然后暴力了,因为一层循环可能遍历的不完全,所以用了双层,分别查找1和2的长辈,用两个数记录两人各有多少长辈

没啥可说的。。

#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct note
{
    int x,y;
} k[3000];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int s=0;
        int t=0;
        int a=1,b=2;
        for(int i=0; i<n; i++)
            scanf("%d %d",&k[i].x,&k[i].y);
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
            {
                if(k[i].x==a)
                {
                    a=k[i].y;
                    s++;
                }
                else if(k[i].x==b)
                {
                    b=k[i].y;
                    t++;
                }
            }

        }
        if(s==t)
            printf("You are my brother\n");
        else if(s>t)
            printf("You are my elder\n");
        else
            printf("You are my younger\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值