poj2082

题目连接
Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5930 Accepted: 3035
Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0.
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑0<=j<=i-1wj <= x <= ∑0<=j<=iwj}
Again, define set S = {A| A = WH for some W , H ∈ R+ and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}.
Your mission now. What is Max(S)?
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy.
But for this one, believe me, it’s difficult.
Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w1h1+w2h2+…+wnhn < 109.
Output

Simply output Max(S) in a single line for each case.
Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1
Sample Output

12
14
Source

Shanghai 2004 Preliminary
思路:这个题永远都是矩形的高乘上能乘的宽度,再比较最大的面积,这个能乘的宽度就是高度比自己高的矩形(没有间隔)宽度之和在加上自己的宽度
代码

//#include<bits/stdc++.h>
#include<iostream>
#include<stack>
#include<algorithm>
#include<string> 
using namespace std;
typedef long long ll;
struct rec{
	ll w,h;
}data;
int main()
{
	ll n;
	while(cin >> n)
	{
		ll i;
		ll ans = 0;
		ll totalw = 0,curarea = 0;//总宽,当前面积 
		if(n==-1) break;
		stack<rec> s;
		ll lasth = 0;//上次进站的矩形高度
		for(i = 0; i < n; i++)
		{
			cin >> data.w >> data.h;
			if(lasth <= data.h)
				s.push(data);
			else
			{
				totalw = 0;
				curarea = 0;
				while(!s.empty()&&s.top().h > data.h)
				{
					totalw += s.top().w;
					curarea = totalw * s.top().h;
					ans = max(ans,curarea);
					s.pop();
				}
				totalw += data.w;
				data.w = totalw;
				s.push(data);//新的矩形 
			}
			lasth = data.h;
		} 
		totalw = 0;
		curarea = 0;
		while(!s.empty())
		{
			totalw += s.top().w;
			curarea = totalw*s.top().h;
			ans = max(ans,curarea);
			s.pop();
		}
		cout << ans << endl;
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值