A + B Again

A + B Again

There must be many A + B problems in our HDOJ , now a new one is
coming. Give you two hexadecimal integers , your task is to calculate
the sum of them,and print it in hexadecimal too. Easy ? AC it !

Input

The input contains several test cases, please process to the end of
the file. Each case consists of two hexadecimal integers A and B in a
line seperated by a blank. The length of A and B is less than 15.

Output

For each test case,print the sum of A and B in hexadecimal in one
line.

Sample Input

+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output

0
2C
11
-2C
-90

16进制下好像不能直接输出负数,得需要先转化一步好像,上代码看。

#include<stdio.h>
int main()
{
	long long n,m,sum;
	while(~scanf("%llx%llx",&n,&m))
	{
		sum=n+m;
		if(sum<0)
		{
			sum=-sum;
			printf("-%llX\n",sum);
		}
		else
		printf("%llX\n",sum);
	}
     return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值