SSL·Asteroids【最小点覆盖】【最大匹配】

Description–

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid . The grid contains K asteroids, which are conveniently located at the lattice points of the grid.
Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
题目给出一个矩阵,上面有敌人,每个子弹可以打出一横行或者一竖行,问最少用多少子弹消灭都有敌人,如:
X.X
.X.
.X.


Input–

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output–

  • Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input–

3 4
1 1
1 3
2 2
3 2

Sample Output–

2

说明–

1 <= N <= 500
1 <= K <= 10,000


代码–

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

int n, k, x, y, ans, l[105], f[105][105];
bool pd[105];

bool find(int o)
{
	for (int i = 1; i <= n; ++i)
	  if (f[o][i] && !pd[i])
	  {
	  	  pd[i] = 1;
	  	  int e = l[i];
	  	  l[i] = o;
          if (!e || find(e)) return 1;
          l[i] = e;
	  }
    return 0;
}

int main()
{
	scanf("%d%d", &n, &k);
	for (int i = 1; i <= k; ++i)
	{
		scanf("%d%d", &x, &y);
		f[x][y] = 1;
	}
	for (int i = 1; i <= n; ++i)
	{
		memset(pd, 0, sizeof(pd));
		if (find(i)) ans++;
	}
	printf("%d", ans);
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值