【POJ3041】【最小点覆盖】【匈牙利】Asteroids

传送门

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input
  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
  • Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2
Sample Output
2
Hint
INPUT DETAILS:

The following diagram represents the data, where “X” is an asteroid and “.” is empty space:

X.X
.X.
.X.
OUTPUT DETAILS:

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

USACO 2005 November Gold


题目大意

题目给出一个矩阵,上面有敌人,每个子弹可以打出一横行或者一竖行,问最少用多少子弹消灭都有敌人,如:

X.X 
.X. 
.X. 

x表示敌人,显然用两个子弹就可以解决所有敌人。


解题思路

每个敌人的位置,横位和竖位连一条边,建一个二分图
横位为一个集合,竖位为一个集合
(横位不能打到横位,竖位不能打到竖位)
从横位打一枪可以打到这个竖位的敌人,从竖位打一枪可以打到这个横位的敌人(同一个敌人)
所以这两个位一线关联,也就是这两个集合多一条线关联

比如,样例建的图就是
在这里插入图片描述

图建出来后,做一个最小点覆盖
在这里插入图片描述经过一系列神神奇奇的证明,反正就是最小点覆盖数用最大匹配做
本题就没必要大材小用 用网络流,直接用匈牙利就可以了


Code
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
struct DT{
	int to, next;
}a[10000];
int num, k, n, x, y, ans, par[510], v[510], head[510];
bool dfs (int gun)
{
	for (int i = head[gun]; i; i = a[i].next)
	{
		int foe = a[i].to;
		if (v[foe]) continue;
		v[foe] = 1;
		if (!par[foe] || dfs (par[foe]))
		{
			par[foe] = gun;
			return 1;
		}
	}
	return 0;
}
int main()
{
	scanf ("%d%d", &n, &k);
	for (int i = 1; i <= k; i++)
	    {
	    	scanf ("%d%d", &x, &y);
	    	a[++num].to = y, a[num].next = head[x], head[x] = num;
	    } 	
	ans = 0;
	for (int i = 1; i <= n; i++)
	    {
	    	memset (v, 0, sizeof (v));
	    	if (dfs (i))
	    	   ans++;
	    }
	printf ("%d", ans);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值