JZOJ·capacitor【数论】

Description–

在这里插入图片描述


Input–

在这里插入图片描述

Output–

在这里插入图片描述


Sample Input–

样例1

2
1 1
3 2

样例2

2
6 5
199 200

Sample Output–

样例1

1
3

样例2

6
200

说明–

在这里插入图片描述


代码–

#include<iostream>
#include<cstdio>

using namespace std;

long long a, b, t, tt, ans;

int main()
{
	freopen("capacitor.in", "r", stdin);
	freopen("capacitor.out", "w", stdout);
	
	scanf("%d", &t);
	for (int i = 1; i <= t; ++i)
	{
	    ans = 0;
		scanf("%lld%lld", &a,&b);
		long long x = a, y = b, r = x % y;
		while (r)//最大公约数
		{
			x = y, y = r;
			r = x % y;
		}
		a /= y, b /= y;
		if (a < b) tt = a, a = b, b = tt;
		while (b != 1)
		{
			a -= b, ans++;
			if (a < b) tt = a, a = b, b = tt;
		}
		printf("%lld\n", a + ans);
	}
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值