Ultra-QuickSort(树状数组+离散化)

Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 50495 Accepted: 18525
Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,
Ultra-QuickSort produces the output
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input

5
9
1
0
5
4
3
1
2
3
0
Sample Output

6

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>

using namespace std;
const int N=500050;
int n,vc[N],va[N];


int lowbit(int x)
{
    return x&-x;
}


struct node
{
    int vl,lc;
}a[N];

bool cmp(node a,node b)
{
    return a.vl<b.vl;
}

void update(int x,int y,int n)
{
    for(int i=x;i<=n;i+=lowbit(i))
        vc[i]+=y;
}

int getsum(int x)
{
    int ans=0;
    for(int i=x;i>0;i-=lowbit(i))
    {
        ans+=vc[i];
    }
    return ans;
}

int main()
{
    while(cin>>n&&n)
    {
        memset(vc,0,sizeof(vc));
        for(int i=1;i<=n;i++)
        {
            cin>>a[i].vl;
            a[i].lc=i;
        }
        sort(a+1,a+n+1,cmp);
        for(int i=1;i<=n;i++)
        {
            va[a[i].lc]=i;//离散化
        }
        long long ans=0;
        for(int i=1;i<=n;i++)
        {
            update(va[i],1,n);
            ans+=i-getsum(va[i]);
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值