PTA甲级 1029 Median (C++)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N ( ≤ 2 × 1 0 5 ) N (≤2×10^5) N(2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-15 13:16:45
// All rights reserved.

#include <iostream>
#include <vector>
#include <queue>

using namespace std;

int main(){

    int num, len1, len2;

    scanf("%d", &len1);
    queue<int> num1;
    for(int i = 0; i < len1; ++i){
        scanf("%d", &num);
        num1.push(num);
    }

    scanf("%d", &len2);
    queue<int> num2;
    for(int i = 0; i < len2; ++i){
        scanf("%d", &num);
        num2.push(num);
    }

    int mid = (len1 + len2 + 1) / 2;
    // mid 表示从 1 开始数,中位数位于第几个

    for(int i = 0; i < mid - 1; ++i){
        if(!num1.empty() && !num2.empty()){
            if(num1.front() <= num2.front()) num1.pop();
            else num2.pop();
        }
        else if(!num1.empty() && num2.empty()) num1.pop();
        else if(num1.empty() && !num2.empty()) num2.pop();
    }

    if(!num1.empty() && !num2.empty()){
        if(num1.front() <= num2.front()) printf("%d\n", num1.front());
        else printf("%d\n", num2.front());
    }
    else if(!num1.empty() && num2.empty()) printf("%d\n", num1.front());
    else if(num1.empty() && !num2.empty()) printf("%d\n", num2.front());

    return 0;
}


在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值