PTA甲级 1041 Be Unique (C++)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [ 1 , 1 0 4 1,10^4 1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N ( ≤ 1 0 5 ) N (≤10^5) N(105) and then followed by N N N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-16 19:32:29
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int main(){
    int n;
    scanf("%d", &n);
    vector<int> d(n);
    unordered_map<int, int> map;
    

    for(int i = 0; i < n; ++i){
        scanf("%d", &d[i]);
        map[d[i]]++;
    }

    int i = 0;
    for(i = 0; i < n; ++i){
        if(map[d[i]] == 1){
            printf("%d\n", d[i]);
            return 0;
        }
    }

    if(i == n) printf("None\n");

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值