PTA甲级 1069 The Black Hole of Numbers (C++)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N N N in the range ( 0 , 1 0 4 ) (0,10^4) (0,104).

Output Specification:

If all the 4 digits of N N N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

Caution:

即使输入的是 6174 也要进行一步减法。

Solution:

// Talk is cheap, show me the code
// Created by Misidrection 2021-08-21 11:26:16
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int main(){
    
    string a;
    cin >> a;
    while(a.length() < 4) a = "0" + a;

    if(a[0] == a[1] && a[1] == a[2] && a[2] == a[3]){
        printf("%s - %s = 0000\n", a.c_str(), a.c_str());
        return 0;
    }

    while(true){

        sort(a.begin(), a.end());
        int small = stoi(a);

        sort(a.begin(), a.end(), greater<char>());
        int big = stoi(a);

        a = to_string(big - small);
        while(a.length() < 4) a = "0" + a;

        printf("%04d - %04d = %s\n", big, small, a.c_str());

        if(a == "6174") break;
        
    }

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值