PTA甲级 1074 Reversing Linked List (C++)

Given a constant K K K and a singly linked list L L L, you are supposed to reverse the links of every K K K elements on L L L. For example, given L L L being 1→2→3→4→5→6, if K K K=3, then you must output 3→2→1→6→5→4; if K K K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N ( ≤ 1 0 5 ) N (≤10^5) N(105) which is the total number of nodes, and a positive K ( ≤ N ) K (≤N) K(N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N N N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

Caution:

刚开始的代码测试点 6 不过,后来查了查其他人的题解发现可能是因为测试点 6 的链表在中间就断开了(后面的就不再属于这个单链表),所以单链表的节点个数可能不是 n,把代码里面表示节点个数的 n 换成 list.size() 之后就AC了。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-21 22:35:42
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>

using namespace std;

int main(){
    string head;
    cin >> head;

    int n, k;
    scanf("%d %d", &n, &k);

    unordered_map<string, pair<int, string>> map;
    for(int i = 0; i < n; ++i){
        string address, next;
        int data;

        cin >> address >> data >> next;

        map[address].first = data;
        map[address].second = next;
    }

    vector<pair<string, int>> list;

    string tmp = head;

    while(tmp != "-1"){
        list.emplace_back(tmp, map[tmp].first);

        tmp = map[tmp].second;
    }

    int pos = 0;
    while(pos < list.size()){
        int right;

        if(pos + k - 1 >= list.size()) break;
        else right = pos + k - 1;

        reverse(list.begin() + pos, list.begin() + right + 1);

        pos = right + 1;
    }
    
    for(int i = 0; i < list.size(); ++i){
        if(i == list.size() - 1) printf("%s %d -1\n", list[i].first.c_str(), list[i].second);
        else printf("%s %d %s\n", list[i].first.c_str(), list[i].second, list[i + 1].first.c_str());
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值