PTA甲级 1123 Is It a Complete AVL Tree (C++)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
在这里插入图片描述
Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( ≤ 20 ) N (≤ 20) N(20). Then N N N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print YES if the tree is complete, or NO if not.

Sample Input 1:

5
88 70 61 63 65

Sample Output 1:

70 63 88 61 65
YES

Sample Input 2:

8
88 70 61 96 120 90 65 68

Sample Output 2:

88 65 96 61 70 90 120 68
NO

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-27 11:38:09
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>
#include <queue>

using namespace std;

struct Node{
    int key;
    Node *left;
    Node *right;

    Node(int k = -1){
        key = k;
        left = NULL;
        right = NULL;
    }
    ~Node(){}
};

Node *LL(Node *r){
    Node *tmp = r -> left;
    r -> left = tmp -> right;
    tmp -> right = r;

    return tmp;
}

Node *RR(Node *r){
    Node *tmp = r -> right;
    r -> right = tmp -> left;
    tmp -> left = r;

    return tmp;
}

Node *LR(Node *r){
    r -> left = RR(r -> left);
    return LL(r);
}

Node *RL(Node *r){
    r -> right = LL(r -> right);
    return RR(r);
}

int getHeight(Node *r){
    if(r == NULL) return 0;
    else return max(getHeight(r -> left), getHeight(r -> right)) + 1;
}

Node *insert(Node *r, int k){
    
    if(k < r -> key){
        if(r -> left == NULL){
            r -> left = new Node(k);
            return r;
        }

        r -> left = insert(r -> left, k);
        if(k < r -> left -> key && getHeight(r -> left) - getHeight(r -> right) == 2) r = LL(r);
        else if(k > r -> left -> key && getHeight(r -> left) - getHeight(r -> right) == 2) r = LR(r);

        return r;
    }
    else{
        if(r -> right == NULL){
            r -> right = new Node(k);
            return r;
        }

        r -> right = insert(r -> right, k);
        if(k > r -> right -> key && getHeight(r -> right) - getHeight(r -> left) == 2) r = RR(r);
        else if(k < r -> right -> key && getHeight(r -> right) - getHeight(r -> left) == 2) r = RL(r);

        return r;
    }
}

int main(){
    int n;
    scanf("%d", &n);

    int tmp;
    scanf("%d", &tmp);

    Node *root = new Node(tmp);
    
    for(int i = 1; i < n; ++i){
        scanf("%d", &tmp);
        root = insert(root, tmp);
    }

    queue<Node*> q;
    vector<int> levelOrder;
    int cnt = 0;
    bool isCBT = true;

    q.push(root);
    while(!q.empty()){
        if(q.front() == NULL){
            if(cnt != n) isCBT = false;

            q.pop();
            continue;
        }

        levelOrder.push_back(q.front() -> key);

        q.push(q.front() -> left);
        q.push(q.front() -> right);
        cnt++;

        q.pop();
    }

    for(int i = 0; i < n; ++i){
        if(i == n - 1) printf("%d\n", levelOrder[i]);
        else printf("%d ", levelOrder[i]);
    }

    if(isCBT) printf("YES\n");
    else printf("NO\n");

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值