PTA甲级 1146 Topological Order (C++)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N ( ≤ 1 , 000 ) N (≤ 1,000) N(1,000), the number of vertices in the graph, and M ( ≤ 10 , 000 ) M (≤ 10,000) M(10,000), the number of directed edges. Then M M M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N N N. After the graph, there is another positive integer K ( ≤ 100 ) K (≤ 100) K(100). Then K K K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
6
5 2 3 6 4 1
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

0 4 5

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-30 12:10:45
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

int main(){
    int n, m, k;
    scanf("%d %d", &n, &m);
    vector<vector<int>> net(n + 1);
    vector<int> degree(n + 1, 0);

    for(int i = 0; i < m; ++i){
        int id1, id2;
        scanf("%d %d", &id1, &id2);

        net[id1].push_back(id2);
        degree[id2]++;
    }

    scanf("%d", &k);
    vector<int> path(n), ans;
    for(int i = 0; i < k; ++i){
        for(int j = 0; j < n; ++j) scanf("%d", &path[j]);

        vector<int> tmpDegree = degree;
        
        for(int j = 0; j < n; ++j){
            if(tmpDegree[path[j]] != 0){
                ans.push_back(i);
                break;
            }
            else{
                int thisNode = path[j];
                for(int k = 0; k < net[thisNode].size(); ++k) tmpDegree[net[thisNode][k]]--;
            }
        }
    }

    for(int i = 0; i < ans.size(); ++i){
        if(i == ans.size() - 1) printf("%d\n", ans[i]);
        else printf("%d ", ans[i]);
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值