PTA甲级 1153 Decode Registration Card of PAT (C++)

该程序处理一组注册卡号及其对应分数的数据,根据不同的查询类型返回各种统计信息。查询类型包括按测试级别输出所有考生、按考试地点统计总人数和总分数,以及按日期统计各地点人数。程序首先解析输入的卡号,然后对数据进行排序和统计,最后按查询要求输出结果。当查询结果为空时,输出'NA'。
摘要由CSDN通过智能技术生成

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N ( ≤ 1 0 4 ) N (≤10^4) N(104) and M ( ≤ 100 ) M (≤100) M(100), the numbers of cards and the queries, respectively.

Then N N N lines follow, each gives a card number and the owner’s score (integer in [ 0 , 100 ] [0,100] [0,100]), separated by a space.

After the info of testees, there are M M M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-30 22:15:59
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>

using namespace std;

struct Student{
    string id;
    int score;

    Student(){
        id = "";
        score = 0;
    }

    ~Student(){}
};

struct Site{
    string name;
    int num;

    Site(string n){
        name = n;
        num = 1;
    }
    ~Site(){}
};

struct Date{
    unordered_map<string, int> sitePos;
    unordered_map<string, bool> valid;
    vector<Site> sites;

    Date(){}
    ~Date(){}
};

bool cmp1(Student &a, Student &b){
    if(a.score != b.score) return a.score > b.score;
    return a.id < b.id;
}

bool cmp2(Site &a, Site &b){
    if(a.num != b.num) return a.num > b.num;
    return a.name < b.name;
}

int main(){
    int n, m;
    Student students[10010];
    int b = 0, a = 0, t = 0;
    unordered_map<string, pair<int, int>> sites;
    unordered_map<string, Date> dates;

    cin >> n >> m;
    for(int i = 0; i < n; ++i){
        cin >> students[i].id >> students[i].score;

        string site = students[i].id.substr(1, 3);
        sites[site].first++;
        sites[site].second += students[i].score;

        string date = students[i].id.substr(4, 6);
        if(dates[date].valid[site] == false){
            dates[date].sites.emplace_back(site);
            dates[date].valid[site] = true;
            dates[date].sitePos[site] = dates[date].sites.size() - 1;
        }
        else dates[date].sites[dates[date].sitePos[site]].num++;
    }

    sort(students, students + n, cmp1);

    for(int i = 0; i < m; ++i){
        int type;
        string term;
        cin >> type >> term;

        printf("Case %d: %d %s\n", i + 1, type, term.c_str());

        if(type == 1){

            int cnt = 0;

            for(int j = 0; j < n; ++j){
                if(students[j].id[0] == term[0]){
                    printf("%s %d\n", students[j].id.c_str(), students[j].score);
                    cnt++;
                }
            }
           
            if(cnt == 0) printf("NA\n");
        }

        else if(type == 2){
            if(sites[term].first == 0){
                printf("NA\n");
                continue;
            }

            printf("%d %d\n", sites[term].first, sites[term].second);
        }
        else{
            if(dates[term].sites.size() == 0){
                printf("NA\n");
                continue;
            }

            sort(dates[term].sites.begin(), dates[term].sites.end(), cmp2);
            for(int j = 0; j < dates[term].sites.size(); ++j)
                printf("%s %d\n", dates[term].sites[j].name.c_str(), dates[term].sites[j].num);

        }
    }

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值