PTA甲级 1135 Is It A Red-Black Tree (C++)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
在这里插入图片描述
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K ( ≤ 30 ) K (≤30) K(30) which is the total number of cases. For each case, the first line gives a positive integer N ( ≤ 30 ) N (≤30) N(30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line “Yes” if the given tree is a red-black tree, or “No” if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

Caution:

建议看一下柳神的博客,思路更清楚。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-06 12:07:53
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

int nums[50];

struct Node{
    int key;
    Node *left;
    Node *right;

    Node(int k){
        key = k;
        left = NULL;
        right = NULL;
    }
    ~Node(){}
};

void insert(Node *r, int k){
    if(r == NULL){
        r = new Node(k);
        return;
    }
    
    if(abs(k) < abs(r -> key)){
        if(r -> left == NULL) r -> left = new Node(k);
        else insert(r -> left, k);
    }
    else{
        if(r -> right == NULL) r -> right = new Node(k);
        else insert(r -> right, k);
    }

    return;
}

bool checkChildren(Node *r){
    // red is -, black is +
    if(r == NULL) return true;

    if(r -> key < 0){
        if(r -> left != NULL && r -> left -> key < 0) return false;
        if(r -> right != NULL && r -> right -> key < 0) return false;
    }

    return checkChildren(r -> left) && checkChildren(r -> right);
}

int getHeight(Node *r){
    if(r == NULL) return 0;
    if(r -> key > 0) return max(getHeight(r -> left), getHeight(r -> right)) + 1;
    return max(getHeight(r -> left), getHeight(r -> right));
}

bool checkHeight(Node *r){
    if(r == NULL) return true;
    
    if(getHeight(r -> left) != getHeight(r -> right)) return false;
    return checkHeight(r -> left) && checkHeight(r -> right);
}

int main(){
    int k, n;
    scanf("%d", &k);

    for(int i = 0; i < k; ++i){
        scanf("%d", &n);

        for(int j = 0; j < n; ++j) scanf("%d", &nums[j]);

        if(nums[0] < 0) printf("No\n");
        else{
            Node *root = new Node(nums[0]);
            for(int j = 1; j < n; ++j){
                insert(root, nums[j]);
            }

            if(!checkChildren(root) || !checkHeight(root)) printf("No\n");
            else printf("Yes\n");
        }
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值