PAT(甲级)2020年秋季考试 7-2 How Many Ways to Buy a Piece of Land (C++)

The land is for sale in CyberCity, and is divided into several pieces. Here it is assumed that each piece of land has exactly two neighboring pieces, except the first and the last that have only one. One can buy several contiguous(连续的) pieces at a time. Now given the list of prices of the land pieces, your job is to tell a customer in how many different ways that he/she can buy with a certain amount of money.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: N ( ≤ 1 0 4 ) N (≤10^4) N(104), the number of pieces of the land (hence the land pieces are numbered from 1 to N N N in order), and M ( ≤ 1 0 9 ) M (≤10^9) M(109), the amount of money that your customer has.
Then in the next line, N N N positive integers are given, where the i-th one is the price of the i i i-th piece of the land.
It is guaranteed that the total price of the land is no more than 1 0 9 10^9 109.

Output Specification:

For each test case, print the number of different ways that your customer can buy. Notice that the pieces must be contiguous.

Sample Input:

5 85
38 42 15 24 9

Sample Output:

11

Hint:

The 11 different ways are:

38
42
15
24
9
38 42
42 15
42 15 24
15 24
15 24 9
24 9

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-08 14:11:52
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

int preSum[10010];

int main(){
    int n, money;
    scanf("%d %d", &n, &money);
    
    for(int i = 1; i <= n; ++i){
        scanf("%d", &preSum[i]);
        preSum[i] += preSum[i - 1];
    }

    int ways = 0;
    for(int i = 1; i <= n; ++i){
        for(int j = i; j <= n; ++j){
            if(money >= preSum[j] - preSum[i - 1]) ways++;
            else break;
        }
    }

    printf("%d\n", ways);

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值