Minimum Inversion Number (线段树)

给定一个整数序列,其逆序数是满足条件i < j且ai > aj的数对数量。通过将序列的前m个元素移到末尾,可以形成n种不同的序列。题目要求找出这些序列中逆序数最小的那个。输入包含多个测试用例,每个用例包含一个正整数n和n个0到n-1的整数排列。输出每个用例的最小逆序数。示例输入和输出展示了问题的解决思路。
摘要由CSDN通过智能技术生成

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

You are asked to write a program to find the minimum inversion number out of the above sequences. 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 

Output

For each case, output the minimum inversion number on a single line. 

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

 

 

 

数据较小,可以暴力:

#include <iostream>
using namespace std;
const int MAX = 5e3 + 5;
int num[MAX];
int main()
{
    ios::sync_with_stdio(false);
    int N;
    while (cin >> N){
        for (int i = 1; i <= N; i++){
        cin >> num[i];
    }
    int sum = 0;
    for (int i = 1; i <= N; i++){
        for (int j = 1; j < i; j++){
            if(num[j] > num[i]){
                sum ++;
            }
        }
    }
    int min = sum;
    for (int i = 1; i < N; i++){
        sum = sum - num[i] + (N - num[i] - 1);
        if (min > sum){
            min = sum;
        }
    }
    cout << min << endl;
    }
    return 0;
}

线段树:

#include <iostream>
#include <algorithm>
using namespace std;
const int MAX = 2e5 +5;
int num[MAX], st[MAX << 2];
void PushUp(int rt){
    st[rt] = st[rt << 1] + st[rt << 1 | 1];
}
void Build (int l, int r, int rt){
    st[rt] = 0;
    if (l == r){
        return ;
    }
    int m = (l + r) >> 1;
    Build(l, m, rt << 1);
    Build(m + 1, r, rt << 1 | 1);
}
void Update(int p, int l, int r, int rt){
    if (l == r){
        st[rt]++;
        return ;
    }
    int m = (l + r) >> 1;
    if (p <= m){
        Update(p, l, m, rt << 1);
    }else {
        Update(p, m + 1, r, rt << 1 | 1);
    }
    PushUp(rt);
}
int Query (int L, int R, int l, int r, int rt){
    if (L <= l && r <= R){
        return st[rt];
    }
    int m = (l + r) >> 1;
    int res = 0;
    if (L <= m){
        res += Query(L, R, l, m, rt << 1);
    }
    if (m < R){
        res += Query(L, R, m + 1, r, rt << 1 | 1);
    }
    return res;       //这里不是pushup()
}
int main()
{
    ios::sync_with_stdio(false);
    int N;
    while (cin >> N){
        Build(0, N - 1, 1);
        int res = 0;
        for (int i = 0; i < N; i++){
            cin >> num[i];
            res += Query(num[i], N - 1, 0, N - 1, 1);    //11
            Update(num[i], 0, N - 1, 1);                 //22  这两行的顺序
        }
        int Min = res;
        for (int i = 0; i < N; i++){
            res = res - num[i] + (N - num [i] - 1);
            Min = min(Min, res);
        }
        cout << Min << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值