PTA-数据结构 编程题01-复杂度2 Maximum Subsequence Sum

本文详细解析了PTA平台上的数据结构编程题——最大子序列和的求解方法。通过输入一系列整数,算法寻找并输出具有最大和的连续子序列及其首尾元素。特别地,当所有数均为负数时,定义最大和为0,并输出整个序列的首尾元素。文章提供了完整的C语言实现代码,展示了如何高效地解决此类问题。
摘要由CSDN通过智能技术生成

PTA-数据结构 编程题01-复杂度2 Maximum Subsequence Sum

在这里插入图片描述
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

参考代码

#include<stdio.h>
#include<stdlib.h>
void MAX(int *p,int N)
 {
 	int i,maxsum,sum=0,max;
 	int m=0,n,flag,count=0;
	maxsum=p[0];max=p[0];
	for(i=0;i<N;i++)
	{
		if(p[i]<0)
		{
			count++;
		}
	}
	if(N==1)
	{
		printf("%d %d %d",p[0],p[0],p[0]);
	}
	else 
	{
		if(count==N)
		{
			
			printf("0 %d %d",p[0],p[N-1]);
		 } 
		else
		{
			for(i=0;i<N;i++)
			{
			 	sum=sum+p[i];
			 	m++;
			 	if(sum>maxsum)
			 	{
			 		maxsum=sum;
			 		n=i;
			 		flag=m;
				 }
				 if(sum<0)
				 {
				 	sum=0;
				 	m=0;
				 }
			}
			printf("%d %d %d",maxsum,p[n-flag+1],p[n]);
		} 
		
	}
	

	
 }
int main()
{
	int *p,N,i;
	scanf("%d",&N);
	p=(int *)malloc(N*sizeof(int));
	for(i=0;i<N;i++)
	{
		scanf("%d",p+i);
	}
	MAX(p,N);
	return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值