PTA-数据结构 编程题02-线性结构3 Reversing Linked List (25 分)

PTA-数据结构 编程题02-线性结构3 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Nextis the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218

33218 3 12309

12309 2 00100

00100 1 99999

99999 5 68237

68237 6 -1

作者: 陈越
单位: 浙江大学
时间限制: 400 ms
内存限制: 64 MB

#include<stdio.h>
#define MAXLEN 100002
struct node 
{
    int Data;
    int next;
};
 
int key, head;
 
struct node Node[MAXLEN];
 
int input( struct node Node[] )     //输入 
{
    int i, Head, Length;
    int address, data, next;
     
    scanf( "%d %d %d", &Head, &Length, &key );
    for ( i = 0; i < Length; i++ )
	{
        scanf( "%d %d %d", &address, &data,  &next );
        Node[ address ].Data = data;
        Node[ address ].next = next;
    }
    return Head;  
}
 
int Count( int head, struct node Node[] )   //有用的节点 
{
    int i, count = 1;
    i = head;
    while( Node[i].next != -1 )
	{
        count++;
        i = Node[i].next;
    }
    return count;
}

void print( int head, struct node Node[] )  //输出 
{
    int putbefor = head;
    while(Node[putbefor].next!= -1)
	{
        printf( "%05d %d %05d\n", putbefor, Node[putbefor].Data, Node[putbefor].next );
        putbefor = Node[putbefor].next;
    }  
    printf( "%05d %d %d", putbefor, Node[putbefor].Data, Node[putbefor].next);
}
 
int change(struct node Node[],int *head,int k)
{
	
	//用 count 求链表的长度   =  count       每次 count--   当 count < k  不反转 
	// p1 = 当前节点     p2 = 下一个节点      p3 =  p2的下一个节点 
	//每执行完一次, k个节点区间内  头尾互换
	//lastend = 前一区块的末端,是上一区间的头节点
	//nexthead = 下一区块的头结点
	//同样也是该区块翻转完后的末端。于是提前用lastend = nexthead保存。 

    int count;
    int i, p1, p2, p3;
	int firstflag=0, nexthead=*head, lastend=-2;
	
	if(k == 1)
        return 0;
    count = Count( *head, Node );
	
    while(count >= k)
	{
        p1 = nexthead;
        p2 = Node[p1].next;
        for( i = 1; i < k; i++ )
		{
            p3 = Node[p2].next;
            Node[p2].next = p1;
            p1 = p2;
            p2 = p3;
         
        }  
		Node[nexthead].next = p3;       //主反转做完后,重新定义头尾节点的指向。
		if(firstflag == 0)
		{
		    lastend = nexthead;
		    *head = p1;//因为在循环中最后改变了ptr2的值,所以此处用ptr1 。
		     
		}
		else
		{
		    Node[lastend].next = p1;
		    lastend = nexthead;
		}
		 
		firstflag++;
		nexthead = p2;
		count -= k;
    }
}
 
int main()
{
    head = input( Node );
    change( Node, &head, key );
    print( head, Node );
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值