B - Number Sequence HDU - 1711----KMP模板

第二天叫醒我的不是闹钟,是梦想!

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1

//找子串首次出现的位置

#pragma GCC optimize(3,"Ofast","inline")
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=1e6+10;
int f[N];
int a[N],b[N];
int n,m;
int t;
void init()
{
  for(int i=2,j=0;i<=m;i++)
  {
    while(j&&b[i]!=b[j+1]) j=f[j];
    if(b[i]==b[j+1]) j++;
    f[i]=j;
  }
}
int main()
{
  scanf("%d",&t);
  while(t--)
  {
    memset(f,0,sizeof f);
    scanf("%d %d",&n,&m);
    for(int i=1;i<=n;i++) scanf("%d",&a[i]);
    for(int i=1;i<=m;i++) scanf("%d",&b[i]);
    init();
    int flag=0;
    for(int i=1,j=0;i<=n;i++)
    {
      while(j&&a[i]!=b[j+1]) j=f[j];
      if(a[i]==b[j+1]) j++;
      if(j==m)
      {
        flag=1;
        printf("%d\n",i-m+1);
        break;
      }
    }
    if(flag==0) puts("-1");
  }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值