Max Sum Plus Plus HDU - 1024----dp+滚动数组优化

第二天叫醒我的不是闹钟,是梦想!

Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 … S x, … S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + … + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + … + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. _

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 … S n.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8

Hint
Huge input, scanf and dynamic programming is recommended.

f[i][j]代表着前j个数,选出i组的最大值。
存在三种情况 一种是不选f[i][j-1]
一种是选当前的不分成新组 f[i][j-1]+v[i]
一种是选当前的分成新祖f[i-1][j]+v[i] 就是把当前组认为只有一个人。
所以f[i][j]=max(f[i][j-1],f[i][j-1]+v[i],f[i-1][j]+v[i]);
但是这道题的数据在1e6,二维都已经超时了,

我们把它优化成一维数组,对于第三种情况而言f[i-1][j]相当于上一组最大的值,用一个一维数组去记录,上一组最大值。


#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=1e6+100;
const int INF=1<<30;
int f[N];
int last[N];
int a[N];
int n,m;
int main()
{
      while(~scanf("%d %d",&n,&m))
      {
        for(int i=1;i<=m;i++) cin>>a[i];
        memset(f,0,sizeof f );
        memset(last,0,sizeof last);
        f[0]=-INF;
        int maxv=0;
        for(int i=1;i<=n;i++)
        {
          maxv=-INF;
          for(int j=i;j<=m;j++)
          {
            f[j]=max(f[j-1]+a[j],last[j-1]+a[j]);
            last[j-1]=maxv;
            maxv=max(maxv,f[j]);
          }
        }
        cout<<maxv<<endl;
      }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值