game----------------------------思维(巴什博弈+PN图)

Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can’t make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

Output
If kiki wins the game printf “Wonderful!”, else “What a pity!”.

Sample Input
5 3
5 4
6 6
0 0

Sample Output
What a pity!
Wonderful!
Wonderful!

Author
月野兔

Source
HDU 2007-11 Programming Contest

解析:
定义两个状态
P:即必败点,某玩家位于此点,只要对方无失误,则必败
N:即必胜点,某玩家位于此点,只要自己无失误,则必胜

三个定理:
一·所有终结点都是必败点P
二.所有一步能走到必败点P的就是N点
三.通过一步操作只能到N点的就是P点

下面就是P/N图
最左下角一定是终结点所以是P
在这里插入图片描述

由上图可知n和m为奇数时,kiki都是必输的

#include <iostream> 
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
int main() {
	int n, m;
	while(~scanf("%d %d",&n,&m)&&n&&m)
	{
		if((n&1)&&(m&1)) cout<<"What a pity!"<<endl;
		else cout<<"Wonderful!"<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值