HDU2767Proving Equivalences

P r o v i n g   E q u i v a l e n c e s Proving\ Equivalences Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9646Accepted Submission(s): 3397

Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

  1. A is invertible.
  2. Ax = b has exactly one solution for every n × 1 matrix b.
  3. Ax = b is consistent for every n × 1 matrix b.
  4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies ©, that © implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to ©, and that © is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
  • m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output
Per testcase:

  • One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input
2
4 0
3 2
1 2
1 3

Sample Output
4
2

Source
NWERC 2008

题目大意:

给出一张图,问最少加几条边能使这张图全图强连通

分析:

直接找很不方便,所以首先把强连通分量找出来,然后缩点,缩点之后的各个点可以组成一张新的有向无环图,现在目标就是找到最少的边使全图强连通,要使全图强连通,只要每个点都存在出度和入度就行了。
记录每个点的出入度,然后统计缺少出度和缺少入度的点的数量,答案就是两者中的最大值。
注意要特判建图后只有一个点的情况,这时答案是0

AC代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 2e4+7;
const int maxm = 5e4+7;
struct EDGE{
	int to,next;
};
int T,n,m,edge_num,index,number,top;
int head[maxn],dfn[maxn],low[maxn],stk[maxn],instk[maxn],scc_id[maxn],indegree[maxn],outdegree[maxn];
EDGE edge[maxm];
void init(){
	edge_num = index = number = top = 0;
	memset(head,255,sizeof(head));
	memset(indegree,0,sizeof(indegree));
	memset(outdegree,0,sizeof(outdegree));
	memset(dfn,0,sizeof(dfn));
	memset(low,0,sizeof(low));
	memset(instk,0,sizeof(instk));
}
void add_edge(int u,int v){
	edge[edge_num].to = v;
	edge[edge_num].next = head[u];
	head[u] = edge_num++;
}
void input(){
	init();
	scanf("%d %d",&n,&m);
	for(int i=0;i<m;i++){
		int pa,pb;
		scanf("%d %d",&pa,&pb);
		add_edge(pa,pb);
	}
}
void tarjan(int u){
	dfn[u] = low[u] = ++index;
	stk[++top] = u; instk[u] = 1;
	for(int i=head[u];i!=-1;i=edge[i].next){
		EDGE &e = edge[i];
		if(!dfn[e.to]){
			tarjan(e.to);
			low[u] = min(low[u],low[e.to]);
		}
		else if(instk[e.to]) low[u] = min(low[u],dfn[e.to]);
	}
	if(dfn[u]==low[u]){
		number++;
		while(stk[top]!=u){
			scc_id[stk[top]] = number;
			instk[stk[top--]] = 0;
		}
		scc_id[stk[top]] = number;
		instk[stk[top--]] = 0;
	}
}
int solve(){
	if(number==1) return 0;
	int in=0,out=0;
	for(int i=1;i<=number;i++){
		if(indegree[i]==0) in++;
		if(outdegree[i]==0) out++;
	}
	return max(in,out);
}
int main(){
	scanf("%d",&T);
	while(T--){
		input();
		for(int i=1;i<=n;i++) if(!dfn[i]) tarjan(i);
		for(int i=1;i<=n;i++){
			for(int j=head[i];j!=-1;j=edge[j].next){
				EDGE &e = edge[j];
				if(scc_id[i]!=scc_id[e.to]) indegree[scc_id[e.to]] = outdegree[scc_id[i]] = 1;
			}
		}
		printf("%d\n",solve());
	}
	return 0;
} 
int solve(){
	if(number==1) return 0;
	int in=0,out=0;
	for(int i=1;i<=number;i++){
		if(indegree[i]==0) in++;
		if(outdegree[i]==0) out++;
	}
	return max(in,out);
}
int main(){
	scanf("%d",&T);
	while(T--){
		input();
		for(int i=1;i<=n;i++) if(!dfn[i]) tarjan(i);
		build();
		printf("%d\n",solve());
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值